Jump to content
LCVG

What is wrong with my XBOX?


Sam P
 Share

Recommended Posts

I dropped out of a game of Rainbow last night and couldn't get back in. I tried restarting but the machine wouldn't restart after being shut off. The ring around the Eject button simply flashed red. There was no picture coming into the TV, nothing.

 

A quick reference of the manual suggested that my XBOX may have been overheating and would return to normal once it cooled down. It seemed perfectly reasonable - it resides inside my AV shelf after all.

 

A night has passed and I just tried booting my machine up with the same results.

 

Uh oh.

 

I tried fiddling with the eject button, removing the disc, unplugging and plugging back in after a short period, but it's still blinking red and giving me no picture.

 

Any ideas? This malfunction happened pretty spontaneously. It's not modded if that makes a difference.

Link to comment
Share on other sites

This might sound like a silly thing to try but just remove the harness from the back the XBOX and replace it firmly. The one that holds all the video and audio connectors. Then just double-check the ends that go to the TV or receiver. From what I remember once I got the box back from service I got a different color other then green, might have been orange or red. I think it was just a way of them telling me hey you forgot to hook up the A/V harness.. I hope this helps.. A shot in the dark but what the heck. Good luck and keep us posted.

 

Just as a side note: I got booted from the same session yesterday and I got a weird message after being booted that I never saw either. I could not reconnect to live and it said I had a DNS error but after about 30 of down time I was back online. Not sure what caused it or fixed it either..

Link to comment
Share on other sites

Thanks for the suggestion Howie! That was one of the first things I tried, however.

 

Anyway, I went to the store last night and got a brand new XBOX at no cost to me. I'm so glad I went for the extended exchange warranty from EB.

 

However, I no longer have any of my saves.

 

I tried RS3 last night but was getting all sorts of new problems. For some reason, I couldn't hear anyone talk in any game because the voices kept cutting out. Even in games with a 3 star connection. Ugh.

 

EDIT: Tried it again this morning.

 

1.) I started getting that DNS problem too. Sometimes I can sign in, other times it boots me to the troubleshooter and tells me there is a problem obtaining DNS.

 

2.) Everything is just working slow, LIVE-wise. From searching for games to checking friends list to connecting, it's all crawling.

 

3.) I went to content download but it won't let me download. I get to the screen that has the download status bar but it sits there for a second, then tells me it was unable to download.

Link to comment
Share on other sites

Kind of dumb suggestion, but when ever we have any problems at all with ours, I call the 800 number. They always are willing to talk me through what ever process I have needed help with, and not only that, when I said it was such a hassle to have to always unplug it from the power strip that sits behind some very heavy furniture, so we can take it to our friends house to connect for gaming sessions, they sent us a free extra power cord. We did not even have to pay for shipping and handling.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...